
This file is also subject to change, modification or cancellation.

****** >>>>>>>VERY IMPORTANT NOTES:<<<<<<<<<<****************
READ THIS ENTIRE TEXT FILE PRIOR TO ATTEMPTING TO USE IT ON
ANY SYSTEM, TO PREVENT LOSS OF CRITICAL FAILURE DATA LOGS.


README File for IBM Hard Disk Drive Identify Utility V2.1 for :

1.12GB F/W Hardfile Option w/Type II Tray PN 94G2649    FRU 06H8560
2.25GB F/W Hardfile Option W/Type II Tray PN 94G2650    FRU 06H8561
1.12GB F/W Hardfile Option W/Type III Tray PN 70G9861   FRU 06H8560
2.25GB F/W Hardfile Option w/Type III Tray PN 70G9862   FRU 06H8561

The Hard Disk Drive Identify Utility V2.1 identifies and instructs
replacement of certain hard disk drives as follows:

1. Within a certain date code range and manufactured for IBM  that
   have exhibited long term reliability problems.
   The failure is due to low fly height which causes
   read/write errors and may eventually cause PFA (Predictive Failure
   Analysis) to trip or hard error, resulting in a defunct drive.
   This is not an early life type of failure and has mostly been seen
   after extensive operation of the drive.

2. This stand-alone utility will identify the drives with this type
   of problem.  The utility will also inspect the drive logs and
   identify the marginal drives (susceptible to future failures).
   Drives that meet either of these two conditions will be replaced.

The utility works with:
   The IBM F/W PCI-Bus RAID Adapter
   The IBM F/W Streaming RAID Adapter/A (Micro Channel)
   The PCI Adaptec SCSI Controller
   The PCI ServeRAID Adapter


        PROCEDURE:

1.  The diskette is bootable.  And it creates a file "LOG" where
    it records the serial number of all hard disk drives in the system
    along with whether replacement is necessary.  The diskette may
    be used on multiple systems.  The file "LOG" is continuously
    appended as the diskette is used on various systems.  It is
    extremely important that the System Serial Number and the
    System Model Number is input correctly since the LOG will
    contain information from various systems. The System Serial
    Number and Model Number is what is used in the file "LOG" to
    identify the pertinent drive information for each specific system.

THIS IS AN EXAMPLE LOG ENTRY
Adapter:0 Channel:2 SCSI_ID:0 PN:86G9153 SN:68D02929RA uC:4141
Adapter:0 Channel:2 SCSI_ID:1 PN:86G9153 SN:68C69871RA uC:4141
Adapter:0 Channel:2 SCSI_ID:2 PN:25H4369 SN:CX52139480 uC:81K1  REPLACE HDD @

Note: If there is no entry that says "REPLACE HDD" then the drive does not need replacement.

2.  Ensure the operator has shutdown the operating system, but has
    not turned power off.

3.  Place the diskette in Drive A: and Warm Boot (CTRL-ALT-DEL) the
    system.

4.  When the diskette boots, it will state the message below.
    Enter 'y' once you have read to continue.

    IBM Hard Disk Drive Identify Utility - Version 2.1

    The Hard Disk Drive Identify program will physically identify
    each hardfile that should be replaced by turning on the
    the hard drives activity light.  This will be an amber light on the type III
    hot swap trays and a green LED visible on the PCB on the bottom
    of the drive.  This happens individually for each hard drive found,
    requiring confirmation by pressing enter

    If there are dissimilar adapters installed in this system, please
    refer to the README file before continuing.

    Press 'y' to continue or any other key to quit:

5.  The program will prompt you for the System Serial Number and
    Model Number.  Enter the Serial Number and Model Number
    carefully.  The program will record in a file "LOG" on the
    diskette all pertinent drive information for this specific serial
    and model number.

6.  The Utility will display "Checking Adapters and Hard Disk Drives.
    This may take several minutes..."

    Once it is complete, hardfiles that should be scheduled for
    replacement will be listed by Adapter, Channel, SCSI_ID,
    Part Number, and Serial Number one at a time.  It will
    also as stated above physically identify the drive by lighting
    the  hard drives activity light.  This will be an amber light on the type III
    hot swap trays and a green LED visible on the PCB on the bottom
    of the drive.
    It is recommended that you mark the drives for easy identification
    and to schedule replacement of these drives.  The program
    does require confirmation from the user by pressing enter
    in order to proceed to the next hardfile.

    If "No Drives Were Found" message is received, then the
    program did not find any hardfiles installed in the system.
    Check to ensure that all procedures were done correctly as
    far as modification of the CONFIG.SYS or the hardware
    configuration as stated above.

    If none of the drives found requires replacement, the
    program will state "No Replacements Necessary."

    NOTE:  Remember when working with Hot Swap Hardfiles, add one
           to the SCSI ID to determine the Bay number of the hardfile.
           You may also ensure that you pulled the correct hard
           drives by verifying that the drive replaced has the same
           serial number as identified by the program.

7.  Upon completion, the utility will state "Hard Disk Drive
    Identify Complete" along with an A: prompt.  Once this
    message is displayed, remove the diskette from the system.

8.  If you have a supply of hard drives to replace the drives
    identified in the system onsite, then at this time follow
    the "FIXED DISK REPLACEMENT PROCEDURES" below to replace
    the hard drives identified by the Hard Disk Drive Update
    Utility in RAID subsystems.

9. Contact your service provider to schedule replacement.

 For NON-RAID and RAID-0 systems
    A.  Ensure that customer has a good tape back up of all
        data on the hard drives being replaced.

    B.  Set the new hard drive to the same SCSI ID and
        termination settings as the old drive.

    C.  Replace the old hard drive with the new hard drive and
        have the customer restore the data to the new hard drive.


10.  If hard disk drive replacements were done, then run the
     utility again to verify that you pulled all the correct
     hardfiles.  The utility should state the following:

     No replacements necessary.
     Hard Disk Drive Identify Complete.
     A:\>

     It is recommended at this time to run diagnostics on the
     SCSI adapter and hard disk drives to ensure that system
     is completely operational.

11.  Repeat the steps above until all systems at the location have
     been done.

12.  When finished with all systems at the location, mark the
     drives to be returned and follow the instruction provided with
     the replacement drives for their return.



FIXED DISK DRIVE REPLACEMENT INSTRUCTIONS:

   The following procedure was developed to assist in implementing
   fixed disk replacement when multiple fixed disks are
   being replaced in a RAID-5 or RAID-1 Array.

               VERY IMPORTANT NOTES:
   NOTE 1:
   The most important points of this procedure are:
   a. Keeping track of which drives are located in which bays and,
   b. To have a backup copy of the customer's RAID configuration.

   NOTE 2:
   The drives may have been swapped out quite a bit.  In the event
   of drive failure, inspect the connectors for damage.

1. Make sure that there are no DDD drives in the system prior
   to starting replacements.
   The Raid utility Raid Admin or Netfinity can be used to determine if
   there are any DDD drives.


2. While still installed in the system, place stickers on the
   drives indicating what bays they are in.  Do the same to the
   new drives once they are installed.

3. BACK UP SYSTEM
    Ensure that operator has a good tape back up of all
    data on the hard drives being replaced.


4. BACK UP CURRENT CONFIGURATION:
   - Soft Boot to the RAID Adapter Option Diskette for the particular
     adapter installed in the system.

     For IBM F/W PCI-Bus Streaming RAID Adapter (FRU p/n 06H5078):
     IBM PCI F/W Streaming RAID Adapter Option Diskette V2.02

     For IBM F/W Streaming RAID Adapter/A (FRU p/n 06H3059 or 92F0335):
     IBM F/W Streaming RAID Adapter/A Option Diskette 1 of 2 V2.31


   - Select option 2 'Start RAID Configuration Program'
           (do this after each reboot)
   - From the Main Menu, Select "Advanced Options"
      - Select "Backup Configuration to Diskette"
      - Insert a blank diskette into drive A:
      - Enter a filename for this backup (default filename is "config")
        Note:  If you use the same backup diskette for more than one
               system, be sure to give each system a different filename
               and keep track of the specific filenames.  PE recommends
               using the system serial number as the filename.

5. PERFORM RAID ARRAY SYNCHRONIZATION

     The procedure of replacing a drive in the RAID involves using
     the RAID drive rebuild capability of the RAID subsystem.
     This will require that the information be rebuilt from the
     parity generated by the synchronization of the array and
     maintained by the adapter as data is updated.

     If the RAID adapter being used is a ServeRAID and you are
     not certain that the synchronization was performed when the
     array was initially configured then you must download
     and use the SynchVerify program and please be sure to
     read and understand the README.

     Data Scrubbing using the synchronization procedure helps ensure that
     the rebuilds of the replaced drives will complete successfully.

     If a drive goes DDD while running data scrubbing using the
     synchronization procedure then it should be replaced and rebuilt.


   - Select "Initialize/Synchronize Array"
   - Select "Synchronize Logical Drive"
   - Press the spacebar to select each logical drive.
   - Once all logical drives are highlighted, press
     enter to begin synchronization.
   - Select "Yes" to confirm.

5. IDENTIFY/REMOVE HOT SPARE DRIVE
    - Exit out of Advanced Options.
      - Select "View Configuration" from the "Main Menu"
      - Identify which bay contains the Hot Spare drive (HSP)
        If there is no HSP drive, proceed to step 5.
    - Gently pull the Hot Spare drive out of its bay
    - Exit out of "View Configuration" and the "Main Menu"
    - Reboot, Press Y to update configuration with HSP bay as DDD.

    NOTE:  Remember, the HOT SPARE drive is pulled out first and is
           left out during replacement/rebuilding of the other drives.
           It then becomes the last drive replaced and its status
           turns to HSP.  The HOT SPARE drive does not require
           rebuilding (it's a spare).

6. REPLACE/REBUILD DRIVES (one at a time)
   You are now ready to pull out the first drive to be replaced.
   Choose an order you would like to replace the drives that the
   Hardfile Identify Utility instructed you to replace.
   Bays 1, 2, 3, 4,etc. Remember the order that you have chosen.
   In order you have chosen, perform the next section


   - Gently pull out drive
   - Reboot the RAID Option Diskette
   - Enter "Y" when prompted to update configuration with DDD drive.
   - System will reboot, wait for the RAID Option Diskette to complete
     boot.
   - Install new drive into the bay.
   - Select "Rebuild Device" off the "Main Menu."
   - Select "Replace Drive"
   - Highlight the correct DDD drive in the bay you are replacing.
     The system will start the drive.
   - After starting successfully, the drive status will change from DDD
     to OFL.
   - Select "Rebuild Device" on the Rebuild Menu off the Main Menu
   - Highlight correct OFL Drive in the bay you are rebuilding.
   - System will rebuild the drive from 0 to 100%.  After it has
     completed successfully, it will change the drive from OFL to ONL.

NOTE: Synchronization is run before any replacements in order
      to ensure that there are no bad sectors on the hardfiles.
      Therefore, you will not receive a REBUILD FAILURE unless
      the drive you are rebuilding has a grown defect.

NOTE: If a REBUILD FAILURE occurs, it will be due to the drive
      that you are rebuilding to and it should be a rare event.
      The synchronization beforehand ensures that all the drives
      you are rebuilding from are good.  You can confirm that the
      failure was due to the drive you are rebuilding by doing the
      following:

1.  Before rebooting, select Drive information on the Main
    Menu.

    Note:  Soft errors initialize to zero upon reboot.
           DO NOT REBOOT before viewing error counters.

2.  View the Drive Information for the drive you just tried
    to rebuild.  You should see Errors on this drive.  Replace
    this drive and start the rebuild again with the new drive.

    Note:  If the soft errors are on a drive that you were
           rebuilding from, do the following:

           - Replace the new drive that you were rebuilding with the
             original drive back into this bay.  This bay will
             indicate OFL status.
           - Exit out to the "Main Menu"
           - Select "Advanced Options"
           - Select "Restore config from diskette"
           - Place the diskette that has the backed up config from
             Step 3 of the previous procedure into drive A:
           - Enter the filename of the saved configuration for
             for this server.
           - Once the RAID configuration has completed being restored,
             all drives should indicate ONL.
           - At this time, remove the drive that was noted as causing
             Soft Errors.
           - Reboot to the RAID Option Diskette.
           - Say "Yes" to update bay that had hard drive with soft
             errors as DDD.
           - When update completes, the RAID Option Diskette will
             update you to reboot the system.
           - Reboot to the RAID Option Diskette.
           - Install the new drive into the DDD bay.
           - Select "Rebuild Device" off the Main Menu.
           - Select "Replace Drive."
           - Highlight the correct DDD Drive in the bay you are
             replacing. (Be careful NOT to select the HSP drive bay)
           - Once the system starts the drive successfully, the bay
             status will change from DDD to OFL.
           - Select "Rebuild Device" on the Rebuild Menu.
           - Highlight the correct OFL Drive in the bay you are
             rebuilding.
           - System will rebuild the drive from 0 to 100%.  After it
             has completed successfully, it will change the drive
             status from OFL to ONL.
           - The Drive with Soft Errors that caused the Rebuild
             Failure has been replaced.  You are now past the Soft
             Errors and can now start replacing the rest of the
             drives proceeding from Step 6.

 IF FATAL ERROR OCCURS DO THE FOLLOWING:

 - Replace only the original drive back into the system that has
   not been rebuilt successfully yet.

 - Restore the configuration from diskette by rebooting to
   RAID Option Diskette.
   - From the Main Menu, select "Advanced Options Menu"
   - Select "Restore Configuration" from diskette
   - Put the diskette with the backup configuration into the diskette
     drive and type in the filename for that particular system.
   - Then, proceed replacing and rebuilding drives wherever you left
     off.

 If during the restoring from diskette an, "ADAPTER IS NOT
 RESPONDING TO CONTROLLER COMMANDS" message appears, do the
 following:

 Reboot and Restore the configuration from the backup RAID
 Support Diskette again until it comes back and says restoration
 completed successfully.

7. REPLACE HOT SPARE DRIVE
   - Once all drives are replaced and rebuilt successfully,
     Replug the Hot Spare Drive back into its bay.
     - From Main Menu select "Rebuild Device"
     - Select "Replace Drive"
     - Highlight the hot spare drive which will have DDD status
     - The system will start the hot spare drive and after
       starting successfully, the drive status will change from
       DDD to HSP.

8. ENSURE ALL SUSPECT DRIVES HAVE BEEN REPLACED.
   - Boot Hardfile Update Utility again to verify that there are
     no more suspect drives installed in the system.
   - The system should now be ready to return to the customer.
